Home  ›  Phones  ›  UTStarcom  ›

UTStarcom PPC-6700 / XV-6700 / HTC Apache


Info Photos News Forum Reviews  100+  

all discussions

HELP! Telus Utstarcom 6700 Won't Boot Passed Telus Screen...


Apr 15, 2008, 2:43 AM
I bought a couple of PPC-6700 phones on an as-is basis to be used as PDA's (mainly for writing word files on the go). Phone functionality isn't important to me at all.

They looked new and both came in the box with all the accessories). They both power on, both go to this screen:

Telus Mobility

H/W=2 P SNAZ-40306
M=12 R 1.05.00
U=4 D 1.04.00 wwe

Then, the picture starts breaking apart and the same process starts over again.

I've tried plugging them in to the cradles, charging the batteries separately, plugging them into the chargers, all with the same result.

Any suggestions?

Apr 15, 2008, 3:37 AM
I think the units' batteries may just be dead. Should these units be able to power on with the power cord plugged in but no battery installed?

Apr 17, 2008, 2:29 AM
For those with a similar problem, a new battery seems to have done the trick.

You must log in to reply.

Please log in to report a message to the moderator.

all discussions

Subscribe to Phone Scoop News with RSS Follow @phonescoop on Threads Follow @phonescoop on Mastodon Phone Scoop on Facebook Follow on Instagram



All content Copyright 2001-2024 Phone Factor, LLC. All Rights Reserved.
Content on this site may not be copied or republished without formal permission.