Home  ›  Phones  ›  Sony Ericsson  ›

Sony Ericsson Z520 / Z525

 

Info Photos News Forum Reviews  100+  

all discussions

Phone Quality...

tombongo

Nov 30, 2005, 9:48 AM
😡 I love the form and function of this phone, but have had issues with its quality. I bought a phone for me and my wife recently from Cingular. I have now had to return THREE phones for new ones. Each one had a different problem.

The first one would not charge. It just kept on saying "DING, optimized charging!", "DING, optimized charging!", "DING, optimized charging!", ...

The second one had an overly sensitive camera button. I am not talking about the normal accidental pictures here. This phone would take pictures in my pocket as I was walking with baggy pants.

I am now about the replace the third one because it makes an awful sound when you open and close it. I thought I could live with the sound, but it is really starting...
(continues)
...
eltupac

Nov 30, 2005, 10:06 AM
I think maybe unlucky. The phone has a glitch when you open it, like a flash, but no sound on mine. It charges and the camera button gets in the way. The only problem I have is the volume on the earpiece. Indoors sounds great, go outside or in a moving car (windows up) and its kinda hard to hear. Maybe I'm going deaf, but it should be louder or at least an firmware upgrade.
...
CrazyOne

Dec 6, 2005, 11:56 PM
Maybe you are going deaf. ;) I can get the earpiece volume up plenty loud to use in moving car, although I sometimes still have ear placement problems (can make a big difference) plus I still have trouble distinguishing the volume buttons from the camera one by feel sometimes. Instead of the volume going up, turns out I'm tapping on the camera button. Or today, it turns out I never heard my end of the ringing when I placed the call, but when the other party picked up, I had the volume up just fine. Blame that on Cingular dead spot, maybe. ;)

I do sometimes get a feedback noise on closing the phone if I don't "End Call" first. Sounds to me like standard mic-speaker feedback from bringing the speaker (earpiece) right up to the mic. No...
(continues)
...
thermophilic

Nov 30, 2005, 3:56 PM
I also had problems with my phone, although not the ones you mention, except for that darn sensitive camera button. I'm on my third Z520 now and so far, so good.

The first phone would occasionally go into silent mode on its own without showing the "silent" icon. I would have to re-start the phone to get the ringer back. Also at times the pulsating menu graphics only showed a pulsating black rectangle.

I exchanged it for another but that one would sometimes show a static-filled caller ID screen when a call came in. It also went into the silent mode by itself once, so back to the Cingular store I went for an exchange.

Otherwise, I love the phone and am willing to give this third one another chance. Anyone else experience these glitch...
(continues)
...

You must log in to reply.

Please log in to report a message to the moderator.


all discussions

Subscribe to Phone Scoop News with RSS Follow @phonescoop on Twitter Phone Scoop on Facebook Subscribe to Phone Scoop on YouTube Follow on Instagram

 

All content Copyright 2001-2020 Phone Factor, LLC. All Rights Reserved.
Content on this site may not be copied or republished without formal permission.