Phone Scoop

printed September 30, 2014
See this page online at:
http://www.phonescoop.com/phones/m_forum.php?fm=m&ff=116&fi=2274079

Home  ›  Phones  ›

Sony Ericsson

Info & Phones News Forums  

Back to message list

T707 \ EQUINOX

by fdavid100    Jan 12, 2010, 10:17 PM

Does anyone else have Sony Ericsson Equinox (T707). I got it at the end of December and it has worked absolutely fine until today.

Today I set the alarm and when it went off I was unable to deactivate because the main menu button doesn't work properly. It only pulls up the ringer volume screen. I was unable to deactivate the alarm for an hour, it kept going into snooze and ringing every 10 minutes. Even after removing the battery 4 times it still rang when reactivated. Without the main menu button there isn't much I can do with the phone.

I tried to update the software and it said it didn't need it.

It said I could reinstall the software from the manufacture if I was still having problems, I did and the problem still exists.

T-mobile is sending me another "Like new" phone. I'm very disappointed in this.

Has anyone else experienced a problem with this otherwise great phone??

Report to moderator

Replies

No replies to this message


Reply You must log in to reply.

Back to message list

‹ all manufacturer forums

Subscribe to Phone Scoop News with RSS Follow @phonescoop on Twitter Phone Scoop on Facebook Phone Scoop on Google+ Subscribe to Phone Scoop on YouTube Follow on Instagram

 

All content Copyright 2001-2014 Phone Factor, LLC. All Rights Reserved.
Content on this site may not be copied or republished without formal permission.
1