Phone Scoop

printed November 26, 2015
See this page online at:

Home  ›  News  ›

Apple Permitting Old Versions of iOS to Install Old Apps

Article Comments  

This forum is closed.

This forum is closed.


Sep 17, 2013, 9:57 PM

Doesn't work for all apps...

Like Google Voice, but my 2g touch did prompt for 'last compatible version' of Facebook.

Sep 17, 2013, 9:29 AM


This might be the first time I can clearly see Apple actually adding value to customers' products instead of trying to force them into something new and more expensive. Not sure where this change in philosophy came from, but nice one Apple.
This is a very good move on Apple's part
Page  1  of 1

Subscribe to Phone Scoop News with RSS Follow @phonescoop on Twitter Phone Scoop on Facebook Subscribe to Phone Scoop on YouTube Follow on Instagram


All content Copyright 2001-2015 Phone Factor, LLC. All Rights Reserved.
Content on this site may not be copied or republished without formal permission.